INTERNAL_SERVER_ERROR: Partial failure to write document parts


I’m receiving the below error while adding documents to the Corpus.

Partial failure to write document parts. Please retry. If the problem persists, contact support. Request failed; contact support if the error persists.

Retrying the request doesn’t solve it.

The same logic that worked earlier doesn’t on repeat tries (after clearing the Corpus).

Can the Vectara team please help solve this?


This resolved automatically. Indexing worked fine after some time.

Just FYI, we did have a fairly short (~40 minute) outage on July 12, and we’re looking to create a status page to make sure we can call these types of things out.

But if you experienced an issue outside of that which was transient, I’d love if you private messaged me your user ID so we can look into if something happened on our side that we should fix

Thanks for the response, Shane.

I didn’t encounter this specific error after the instance I shared. I will reach out if I face it again.